


             Pl

2           About this Guide

• • • •••

• • • •••
    ABOUT THIS GUIDE

This User Guide is a reference for Platypus. You can read from start to finish 
or jump around as you please. This guide is available in Acrobat PDF format.

Copyright
No part of this document may be reproduced or transmitted in any form or by 
any means, electronic or mechanical, including photocopying and recording, 
for any purpose without the express written consent of Duke University.

Copyright © Duke University, LLC. 2015. All Rights Reserved

July 23, 2015

Attribution
Platypus was created as a collaborative effort by Rujie Yin, David Dunson and 
Ingrid Daubechies of Duke University; Bruno Cornelis of the Free University 
Brussels; Bill Brown and Noelle Ocon of the North Carolina Museum of Art; 
Digital Film Tools.
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    INSTALLATION

1 Download Platypus from the Platypus project website at: http://www.project-
platypus.net/temporary/main/

2 Double-click on the file that was downloaded and run through the installation 
process.

3 Start Photoshop and load a grayscale image.
4 Select Platypus from Photoshop Filter menu.

The Platypus user interface opens.
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    UNINSTALLING

Windows
From the Windows Start Menu, select Programs > Platypus > Uninstall 
Platypus.

Macintosh
Go to Applications/Platypus and double-click on Uninstall Platypus.
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    PLATYPUS

Description
Platypus removes the deleterious effect of cradling on X-ray images of 
paintings on wooden panels. The algorithm consists of a three stage 
procedure. First, the cradled regions are located automatically. The second 
step consists of separating the X-ray image into a textural and image 
component. In the last step, the algorithm distinguishes between the texture 
caused by the wooden cradle and the texture belonging to the original painted 
wooden panel and removes only the wood grain texture which cannot be done 
manually in Adobe Photoshop™.

Background
Between the 12th to the 17th century, paintings in Europe were mostly created 
on wooden panels consisting of solid wooden boards. Until about 1950, 
cradling was a common restoration technique used by conservators to 
remediate or prevent structural or insect damage. In the process, the panels 
were first thinned, and then strengthened by permanently attaching to their 
backs hardwood lattices called cradles.

Although invisible when a cradled panel painting is on display, the cradles show 
up in X-ray images, which are intensively studied by art experts and museum 
conservators to learn artist technique, painting fabrication, and the physical 

Before After
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condition of the painting. To remove these cradle artifacts from X-ray images, 
experienced museum conservators do it manually Adobe Photoshop™. As a 
labor intensive task, this is done only on a small portion of the whole collection 
of museums' panel paintings. Therefore, a semi-automated algorithm is 
welcomed by museum conservators which can save their time and effort on 
removing the cradle image from X-ray images.

Features
• Automatic detection of cradle region location
• Separation of the X-ray image into textural and image components
• Black, Gamma and White point adjustments of the removed cradle sections
• Removal of the cradle’s wood grain texture
• Ability to manually override automatic features
atypus User Guide
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    TUTORIALS

1 Start Photoshop.
2 Load the cradle.jpg image located at:

• Macintosh: /Applications/Platypus/images
• Windows: C:/Program Files/Platypus/images
Note: Platypus only works with grayscale images. If you are using a color image, select 
the Image > Mode > Grayscale Photoshop menu item.

3 Select Layer > Duplicate Layer.
This creates a duplicate layer that Platypus can be applied to.

4 Apply Platypus from the Filters menu.
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The Platypus user interface consists of tools, tabs and a viewer.

Automatic Cradle Detection
1 Click the Detect Cradle icon.

Tools

Tabs

Viewer
atypus User Guide
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2 In the Detect Cradle windows that opens, click Auto Detect.

The cradle detection algorithm runs and display the detected cradle sections as 
an overlay.
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3 If the result of the cradle detection needs to be fine tuned, edit the points as 
needed.
Go to the Polygon Editing Keyboard Shortcuts to see the different ways to 
edit polygons.

4 If the cradle detection is not successful with the image you are using, click the 
Detect Cradle icon again, select Assisted Detect and enter the number of 
horizontal and vertical members.
Assisted Detect helps the automatic cradle detection by entering the number of 
horizontal and vertical members. 

See Assisted Detect for more information.

If the cradle detection is still not successful, you will need to manually draw the 
cradle sections. To do this, you can use the Polygons tool.

5 Press Ctrl(Win)/Cmd(Mac)-Z to undo the cradle detection.

Manual Cradle Creation
1 Click the Polygons icon to select it or press E.
atypus User Guide
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2 To create a polygon, click and drag over a cradle section to create a shape.

3 Click and drag the points to fine tune the shape.
Platypus User Guide    
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4 Draw additional polygons over the remaining cradle sections or copy and paste 
an existing polygon using Ctrl(Win)/Cmd(Mac)-C to copy and 
Ctrl(Win)/Cmd(Mac)-V to paste and then edit the points as needed.

Go to the Polygon Editing Keyboard Shortcuts to see the different ways to 
edit polygons.

If there are areas of the image that you would like to exclude from processing, 
use the Mask tool to draw a shape over the area. The masked area will then be 
excluded from any further cradle detection, removal and texture replacement.

See Mask for more information.
atypus User Guide
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Removing the Cradles
1 Press the Remove Cradle icon.

The cradle removal algorithm runs, removes the cradle sections and switches 
to the Remove tab.

2 Select the Toggle Overlay icon or press Q to remove the cradle overlay from the 
image.
Platypus User Guide    
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3 Toggle the Show Result button to see the difference between the original image 
and the cradle removal.

4 If you would like to save cradle for later use, select File > Save Cradle.
Some of the cradle sections may need their Black, Gamma or White point 
adjusted.

5 Toggle the Overlay icon or press Q to turn the cradle overlay back on.

6 Click on a cradle section to select it. Adjust the Black, Gamma and White sliders 
as needed.
While you adjust the sliders, the overlay disappears. 

7 If you Alt-click on another cradle section, the Black, Gamma and White 
adjustments from the first section are applied to the new section.
Note: Cradle sections can be selected and adjusted, even though you can’t see the 
selection. Just click on the cradle section to select it and then adjust it using the sliders.

Cradle Texture Replacement
1 Select the Remove tab.

In the Remove tab, there is a Remove Texture option. When selected, the 
cradle algorithm distinguishes between the texture caused by the wooden 
cradle and the texture belonging to the original painted wooden panel and 
removes only the wood grain texture.

Warning: The Remove Texture phase is time/memory intensive and takes a long time 
to render.

2 Click Remove Texture.
atypus User Guide
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A progress bar appears at the bottom left of the Platypus user interface and 
displays the result when it is finished.

3 Click the Done button to apply the filter to your image.

The resulting image from Platypus is transferred to Photoshop.
Platypus User Guide    
• • •••



             Pl

16           Platypus User Interface

• • • •••

• • • •••
    PLATYPUS USER INTERFACE

The Platypus user interface consists of tools, tabs and a viewer.

Platypus Controls
The Platypus controls are organized using tabs. There are Mark, Remove and 
Texture tabs. Within each tab are associated tools.

Tools

Tabs

Viewer
atypus User Guide
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Mark
The Mark tab includes tools for automatically or manually defining the cradle 
pieces and triggering the cradle removal.
Platypus User Guide    
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Automatic Tools
Detect Cradle
Opens the Detect Cradle window.

Auto Detect
Automatically detects cradle sections and draws them as an overlay on the 
image.

Assisted Detect
When enabled, the cradle detection algorithm uses the numeric values entered 
for Horizontal and Vertical members and draws them as an overlay on the 
image.

Horizontal Members
Defines the number of horizontal cradle members.

Vertical Members
Defines the number of vertical cradle members.

Remove Cradle
Automatically removes the cradle. Once clicked, the Remove tab is 
automatically selected.
atypus User Guide
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Manual Tools
Polygons (e)
Creates a square or rectangular polygon.

To create a polygon, click and drag to create a shape.

Polygon Editing Keyboard Shortcuts

Mask (m)
Draws a bézier shape that is used to define areas to be excluded from the 
cradle detection, removal and texture replacement.

Invert Mask (i)
Inverts the mask.

Shortcut Action

Click-drag over image Creates a polygon

Click-drag a point Moves a polygon point

Alt-drag selected polygon edge Moves two corner points simultaneously

Alt-drag over open space on image Rotates the selected polygon

Ctrl(Win)/Cmd(Mac)-click polygon Toggles the polygon selection

Shift-drag over polygons Selects multiple polygons

Arrow Keys Moves selected shapes

Arrow Keys+Hover over point Moves point
Platypus User Guide    
• • •••
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Alt-click on one of the shape boundaries to add a point. The added point will 
have a control point and tangent handle that can define the form of the curve.

Mask Keyboard Shortcuts

Control Point

Tangent Handle

Tangent

Curve Join

Shortcut Action

Click-drag over image Creates a mask

Click-drag a point Moves a mask point

Alt-drag a point Turn a corner point into a smooth point

Ctrl(Win)/Cmd(Mac)-drag a tangent Adjust both tangents simultaneously and equally

Alt-drag over open space on image Rotates the selected mask

Ctrl(Win)/Cmd(Mac)-click polygon Toggles the mask selection

Shift-drag over polygons Selects multiple mask

Arrow Keys Moves selected shapes

Arrow Keys+Hover over point Moves point
atypus User Guide
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Remove
Show Result

Displays the result of the cradle removal. Disabling Show Result displays the 
original image.

Black
Adjusts the black point of the selected cradle sections.

Gamma
Adjusts the midtones of the selected cradle sections.
Platypus User Guide    
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White
Adjusts the white point of the selected cradle sections.

Note: Cradle sections can be selected and adjusted, even with the Overlay being 
hidden. Just click on the cradle section to select it and then adjust it using the sliders.

Remove Keyboard Shortcuts

Shortcut Action

Left/Right Arrow keys while hovering 
over Black, Gamma or White sliders

Adjusts the slider in fine increments.

Alt-click a new cradle section The Black, Gamma and White settings from the selected 
cradle section are transferred to the newly clicked cradle
atypus User Guide
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Texture
Remove Texture

The cradle algorithm distinguishes between the texture caused by the wooden 
cradle and the texture belonging to the original painted wooden panel and 
removes only the wood grain texture.

Warning: The Remove Texture phase is time/memory intensive and takes a long time 
to render.
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Viewer
The Viewer controls manipulate how images are viewed and edited.

Zoom 1:1 (h)
Sets the Viewer to a 1:1 zoom ratio and shows the actual pixels of the image.

Zoom to Fit (f)
Fits the entire image inside the Viewer.

Zoom In (i)
Zooms the image in.

Zoom Out (o)
Zooms the image out.

Toggle Overlay (q)
Toggles the display of the cradle marking overlay on and off.
atypus User Guide
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Viewer Keyboard Shortcuts

Done, Reset, Cancel
Done

The image created in the Platypus user interface is transferred to Photoshop.

Reset All
Resets Platypus back to it’s default settings.

Cancel
Closes the Platypus user interface without making any changes.

Shortcut Action

Space Bar-drag Pans the image

I Key Zooms the image in

O Key Zooms the image out

Scroll wheel over image Zooms the image in and out

Middle-mouse double click Fits the image to the window

F Fits the image to the window

H Sets the image to a 1:1 pixel ratio
Platypus User Guide    
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    PULL-DOWN MENUS

File
Open Cradle
Opens a previously saved cradle so that you can pick up editing where you left 
off.

Save Cradle
Saves the current cradle setup which can reloaded at a later time.

Save Cradle As
Saves the currently saved cradle as a new file.

Edit
Undo/Redo

Undo or redo operations.

Cut
Cuts the selected objects.

Copy
Copies the selected objects.

Paste
Pastes the selected objects.

Delete
Deletes the selected objects.

View
Zoom to Fit (f)

Zoom the image to fit the window.
atypus User Guide
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Zoom to 1:1 (h)
Zooms the image to a 1:1 pixel ratio.

Zoom In (i)
Zooms the image in.

Zoom Out (o)
Zooms the image out.

Help
User Guide

Opens the Platypus User Guide.

Help Shortcuts

About
Shows the Platypus version.

Shortcut Action

F1 Opens the Platypus User Guide
Platypus User Guide    
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